Advisory record · GHSA-f25v-x6vr-962g

Pheditor: Authentication Bypass in Forced Password-Change Flow via Unverified Current Password

CVSS 10.0 CriticalCritical

Critical, because:

  • CVSS score 10.0: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 24 Jul 2026, 21:54 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
pheditor/pheditorPackagist<2.0.82.0.8
Identifiers
GHSA-f25v-x6vr-962g · PKSA-jw7m-7sxt-c8zt
Weakness (CWE)
CWE-1392
Published
24 Jul 2026
Updated
24 Jul 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Pheditor versions before 2.0.8 are affected. On instances where the default password has not been changed, the forced password-change flow does not check the submitted password against the current one, so an unauthenticated remote attacker can set a new admin password and obtain an authenticated session. Upgrade to Pheditor 2.0.8. The source lists no other workaround.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
10.0 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:24 UTC First seen by agentprime
  2. 31 Oct 2026, 14:24 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.