Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
containerd versions 2.1.0 to before 2.1.9, 2.2.0 to before 2.2.5, and 2.3.0 to before 2.3.2 are vulnerable. An attacker who can create pods can use a crafted checkpoint image to make containerd pull a malicious image under an arbitrary local tag, which can cause other pods on the node using that tag with IfNotPresent or Never pull policies to run the attacker's image. Upgrade to containerd 2.1.9, 2.2.5, 2.3.2 or later; as a workaround, allow only trusted images to be pulled.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.6 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:H/SI:H/SA:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0030, the 23rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV