Advisory record · GHSA-cvw4-c69g-7v7m

Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js

CVSS 0.0 NoneEPSS 0.014 · 73rd percentile

Published by the GitHub Advisory Database at 2 Jul 2024, 21:20 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
ethyca-fidesPyPI<2.39.12.39.1
Identifiers
GHSA-cvw4-c69g-7v7m · CVE-2024-38537 · PYSEC-2026-1339
Weakness (CWE)
CWE-829
Published
2 Jul 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Fides' fides.js script (PyPI package ethyca-fides, versions before 2.39.1) loaded code from the polyfill.io domain for legacy browsers such as IE11 that lack fetch support. Users of those legacy browsers who visited a page serving fides.js could have downloaded and run malicious scripts from the compromised domain. Upgrade to ethyca-fides 2.39.1 or later. The source notes that Cloudflare and Namecheap later blocked polyfill.io from resolving, which made the issue unexploitable.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
0.0 None 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.014, the 73rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.