Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Yamcs (org.yamcs:yamcs-core) versions 5.13.0 before 5.13.2 and versions before 5.12.8 are affected. Three IAM API endpoints, which list roles and privileges, lack authorization checks, so any authenticated user can retrieve the full privilege list and role definitions, which the source says could help plan privilege escalation. Upgrade to version 5.13.2 or 5.12.8. The source gives no workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0034, the 27th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cvw4-55pp-3hfq
- OSV: GHSA-cvw4-55pp-3hfq
- github.com/yamcs/yamcs/security/advisories/GHSA-cvw4-55pp-3hfq
- github.com/yamcs/yamcs/commit/c2aec1c242e656e48b52c7f87deea88183bb592d
- github.com/yamcs/yamcs/commit/dcaec5f0b2f4231b8e313e94d79a937169c9e0ba
- github.com/yamcs/yamcs
- github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8
- github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2