Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PraisonAI (PyPI package praisonai) versions before 4.6.78 are vulnerable. The find command remains on the safe command allowlist, and its built-in -exec, -execdir and -delete actions can run other programs or delete files without shell metacharacters, bypassing the shell command restrictions. An attacker who can influence the shell tool's command input, including through prompt injection of an LLM agent, could read blocked files, delete files, or run non-allowlisted programs. Upgrade to praisonai 4.6.78 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0073, the 54th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV