Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Two packages are affected: go.mongodb.org/mongo-driver before 1.17.7 and go.mongodb.org/mongo-driver/v2 before 2.4.2. The flaw is a heap out-of-bounds read in the GSSAPI (Kerberos) authentication code, where error-message strings are assumed to be null-terminated, causing a read one byte past a heap buffer. The source gives few details on how an attacker would trigger this or what the read exposes. Upgrade to 1.17.7 or 2.4.2, depending on which module is in use.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.9 | Medium | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (mongodb) |
- CISA KEV Not listed.
- EPSS 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:13 UTC First seen by agentprime
- 31 Oct 2026, 14:13 UTC Confirmed by OSV