Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Dulwich versions 0.22.5 up to (but not including) 1.2.8 are vulnerable to a symlink directory traversal in the stash pop operation, which can write files outside the repository worktree. An attacker who supplies a malicious repository can get a victim to clone it and pop a stash, causing attacker-controlled content to be written to arbitrary locations, such as git hooks that run code on a later checkout. Upgrade dulwich to version 1.2.8 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.3 | High | 4.0 | CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0015, the 4th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV