Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Next.js versions 16.0.0 through before 16.3.8 are vulnerable to server-side request forgery in Image Optimization, where an attacker-controlled remote URL that is allow-listed can cause the server to make requests to private IP addresses. The source does not describe the exact attacker access required beyond supplying a URL that matches an allow-listed pattern. Upgrade next to version 16.3.8, which is the listed fix; the source's workaround is to audit hosts in images.remotePatterns that may not be trusted with their DNS entries, and apps with no remotePatterns configured are not affected.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.3 | High | 4.0 | CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0033, the 26th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:33 UTC First seen by agentprime
- 31 Oct 2026, 13:33 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cjq9-62q9-8jv4
- OSV: GHSA-cjq9-62q9-8jv4
- github.com/vercel/next.js/security/advisories/GHSA-cjq9-62q9-8jv4
- nvd.nist.gov/vuln/detail/CVE-2026-94483
- github.com/vercel/next.js/commit/e002ad68bd676bb0ed0c87bb22e3590304763e0b
- github.com/vercel/next.js
- github.com/vercel/next.js/releases/tag/v16.3.8