Advisory record · GHSA-cgx6-hpwq-fhv5

Integer Overflow or Wraparound in libxml2 affects Nokogiri

CVSS 8.6 High

Published by the GitHub Advisory Database at 18 May 2022, 20:06 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
nokogiriRubyGems<1.13.51.13.5
Identifiers
GHSA-cgx6-hpwq-fhv5 · CVE-2022-50999
Weakness (CWE)
CWE-190
Published
18 May 2022
Updated
27 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Nokogiri versions before 1.13.5, when using the packaged libxml2 on CRuby, are affected by integer overflow flaws in libxml2's buffer handling (CVE-2022-29824). An attacker who can get a victim to open a crafted multi-gigabyte XML file could cause out-of-bounds memory writes, leading to information disclosure or denial of service. Upgrade to Nokogiri 1.13.5 or later.

Written 8 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
8.6 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 15:16 UTC First seen by agentprime
  2. 31 Oct 2026, 15:16 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.