Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Lightning (the PyTorch Lightning package) versions before 2.3.3 are vulnerable to remote code execution. The flaw lies in how the library handles deserialized user input through deepdiff Delta objects, which can be crafted to bypass restrictions on dunder attributes. An attacker who can reach the delta endpoint, which is enabled by default, may run code on self-hosted applications. Upgrade to version 2.3.3 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.0 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CNA (@huntr_ai) |
- CISA KEV Not listed.
- EPSS 0.27, the 98th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:10 UTC First seen by agentprime
- 31 Oct 2026, 14:10 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cgwc-qvrx-rf7f
- OSV: GHSA-cgwc-qvrx-rf7f
- nvd.nist.gov/vuln/detail/CVE-2024-5452
- github.com/Lightning-AI/pytorch-lightning/issues/20038
- github.com/lightning-ai/pytorch-lightning/commit/330af381de88cff17515418a341cbc1f9f127f9a
- github.com/Lightning-AI/pytorch-lightning/releases/tag/2.3.3
- github.com/lightning-ai/pytorch-lightning
- huntr.com/bounties/486add92-275e-4a7b-92f9-42d84bc759da