Advisory record · GHSA-cgvx-9447-vcch

ntlk unsafe deserialization vulnerability

CVSS 7.5 HighEPSS 0.013 · 71st percentile

Published by the GitHub Advisory Database at 28 Jun 2024, 00:33 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
nltkPyPI<3.93.9
Identifiers
GHSA-cgvx-9447-vcch · CVE-2024-39705 · PYSEC-2024-167
Weakness (CWE)
CWE-300 · CWE-502
Published
28 Jun 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The nltk package, versions before 3.9, is vulnerable to unsafe deserialization. If untrusted data packages containing pickled Python code are downloaded through NLTK's built-in data download functionality, an attacker can achieve remote code execution. The source names averaged_perceptron_tagger and punkt as examples affected by this. Upgrade nltk to version 3.9 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS 0.013, the 71st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.