Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The pypdf PyPI package, versions before 6.21.4, is vulnerable to large memory usage when parsing a PDF's page tree. An attacker who supplies a specially crafted PDF with many shared resources can cause excessive memory consumption when it is parsed. The fix is to upgrade to pypdf 6.21.4; if an upgrade is not yet possible, the source suggests applying the changes from pull request #4290.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.1 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0022, the 12th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 29 Oct 2026, 20:34 UTC Confirmed by the CVE List
- 29 Oct 2026, 21:17 UTC Confirmed by NVD
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cggf-277g-3q54
- OSV: GHSA-cggf-277g-3q54
- github.com/py-pdf/pypdf/security/advisories/GHSA-cggf-277g-3q54
- nvd.nist.gov/vuln/detail/CVE-2026-119204
- github.com/py-pdf/pypdf/pull/4290
- github.com/py-pdf/pypdf/commit/ea4ac663133f1b3de1d7a8f2e6fa239802fde79e
- github.com/py-pdf/pypdf
- github.com/py-pdf/pypdf/releases/tag/6.21.4