Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Black versions before 26.10.1 have a vulnerability in the GitHub Action bundled with Black when `use_pyproject` is set to True: the version read from `tool.black.required-version` in pyproject.toml is installed without validation. An attacker who can submit a pull request to the victim's repository could point this value at a malicious source and run code in the context of the repository. Upgrade to Black 26.10.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS No score.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
- 5 Nov 2026, 20:22 UTC Confirmed by the CVE List
- 5 Nov 2026, 21:18 UTC Confirmed by NVD