Advisory record · GHSA-cf98-j28v-49v6

OpenFGA Improper Policy Enforcement

CVSS 2.1 LowEPSS 0.0034 · 27th percentile

Published by the GitHub Advisory Database at 18 Jun 2026, 15:05 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/openfga/openfgaGo<1.18.01.18.0
Identifiers
GHSA-cf98-j28v-49v6 · CVE-2026-55170 · GO-2026-5322
Weakness (CWE)
CWE-178
Published
18 Jun 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

OpenFGA (github.com/openfga/openfga) versions before 1.18.0 are vulnerable when MySQL is used as the datastore: two distinct check requests can return the same response. The source gives few details on how this is triggered, but it applies when authorization decisions rely on case-sensitive user strings. Upgrade to version 1.18.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
2.1 Low 4.0 CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0034, the 27th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:13 UTC First seen by agentprime
  2. 31 Oct 2026, 14:13 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.