Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Nginx UI (Go module github.com/0xJacky/Nginx-UI) versions before 1.9.10-0.20260703131214-23d1934099b0 are affected. The nginx config directive denylist can be bypassed by placing a blocked directive after a semicolon on the same line as a benign one. An authenticated user can use this to inject directives such as user root or js_* and, where the njs module is present (as in the official Docker image), execute code in the nginx worker. Upgrade to 1.9.10-0.20260703131214-23d1934099b0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.8 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0051, the 43rd percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:11 UTC First seen by agentprime
- 31 Oct 2026, 14:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cf23-7qxj-xmhr
- OSV: GHSA-cf23-7qxj-xmhr
- github.com/0xJacky/nginx-ui/security/advisories/GHSA-cf23-7qxj-xmhr
- nvd.nist.gov/vuln/detail/CVE-2026-84316
- github.com/0xJacky/nginx-ui/commit/23d1934099b05b2a01589b48129dc3d3159d91c2
- github.com/0xJacky/nginx-ui
- github.com/0xJacky/nginx-ui/releases/tag/v2.4.1