Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's netty-codec-haproxy Maven package is affected in versions 4.2.0.Final up to but not including 4.2.15.Final, and in versions below 4.1.135.Final. An attacker who can send crafted HAProxy PROXY protocol headers to a server using this decoder can supply an invalid SSL TLV length, causing a memory leak of the retained buffer slice on each such message. The source gives few details on how much memory is lost or whether this leads to denial of service. Upgrade to 4.2.15.Final or 4.1.135.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0062, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-cc37-9q2j-3hfv
- OSV: GHSA-cc37-9q2j-3hfv
- github.com/netty/netty/security/advisories/GHSA-cc37-9q2j-3hfv
- nvd.nist.gov/vuln/detail/CVE-2026-44893
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.135.Final
- github.com/netty/netty/releases/tag/netty-4.2.15.Final