Advisory record · GHSA-c65f-x25w-62jv

openssl-encrypt has CORS wildcard with allow_credentials=True in standalone servers

CVSS 7.1 HighEPSS 0.0036 · 30th percentile

Published by the GitHub Advisory Database at 1 Apr 2026, 21:12 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
openssl-encryptPyPI<1.4.01.4.0
Identifiers
GHSA-c65f-x25w-62jv · CVE-2026-74881 · PYSEC-2026-3977
Weakness (CWE)
CWE-863 · CWE-942
Published
1 Apr 2026
Updated
11 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

The openssl-encrypt package before 1.4.0 configures its standalone servers with a wildcard CORS origin policy that also allows credentials. A website visited by a user could make authenticated cross-origin API requests on that user's behalf. Upgrade to openssl-encrypt 1.4.0 or later.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.1 High 4.0 CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N CNA (VulnCheck)
  • CISA KEV Not listed.
  • EPSS 0.0036, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:10 UTC First seen by agentprime
  2. 31 Oct 2026, 14:10 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.