Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Yamcs (org.yamcs:yamcs-core) versions 5.13.0 up to but not including 5.13.2, and versions below 5.12.8, are vulnerable. An authenticated user with a read-only archive privilege, such as ReadEvents, ReadTables, or ReadActivities, can send a LIKE pattern containing a double quote to break out of the generated Java code. This allows arbitrary OS command execution as the user running Yamcs. Upgrade to 5.13.2 or 5.12.8, which contain fixes.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.9 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0065, the 51st percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-c64q-hj4j-375f
- OSV: GHSA-c64q-hj4j-375f
- github.com/yamcs/yamcs/security/advisories/GHSA-c64q-hj4j-375f
- github.com/yamcs/yamcs/commit/640e1598b7097b521692e89dd47a39b6cb1fc663
- github.com/yamcs/yamcs/commit/a8fb4a0693fa62a6eb729b26016d1090dd8b289c
- github.com/yamcs/yamcs
- github.com/yamcs/yamcs/releases/tag/yamcs-5.12.8
- github.com/yamcs/yamcs/releases/tag/yamcs-5.13.2