Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The amqp091-go library, Go package github.com/rabbitmq/amqp091-go, is vulnerable in versions before 1.13.0. When a long string inside a table field declares a length above 2^31 - 1, the parser returns an empty string without consuming the data, which desynchronizes the stream. An attacker who can send AMQP traffic to a client or server using this library could potentially inject frames and hijack the connection. Upgrade to version 1.13.0 or later. The source gives few details on exploitation conditions and does not list a workaround.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.5 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:12 UTC First seen by agentprime
- 31 Oct 2026, 14:12 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-c5pq-fr2g-9jpf
- OSV: GHSA-c5pq-fr2g-9jpf
- github.com/rabbitmq/amqp091-go/security/advisories/GHSA-c5pq-fr2g-9jpf
- nvd.nist.gov/vuln/detail/CVE-2026-77411
- github.com/rabbitmq/amqp091-go/pull/347
- github.com/rabbitmq/amqp091-go/commit/143c1ace5fa7344cee135e5c7d22970f0de68282
- github.com/rabbitmq/amqp091-go
- github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0