Advisory record · GHSA-c5cj-xp43-qcc3

Moodle's error handling leads to sensitive information disclosure

CVSS 5.3 MediumEPSS 0.0030 · 22nd percentile

Published by the GitHub Advisory Database at 23 Oct 2025, 12:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
moodle/moodlePackagist>=5.0.0-beta, <5.0.3 || >=4.5.0-beta, <4.5.75.0.3, 4.5.7
Identifiers
GHSA-c5cj-xp43-qcc3 · BIT-moodle-2025-62396 · CVE-2025-62396 · PKSA-s9t3-1mh7-mgx2
Weakness (CWE)
CWE-548
Published
23 Oct 2025
Updated
18 Nov 2025

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Moodle versions 4.5.0-beta through 4.5.6 and 5.0.0-beta through 5.0.2 are affected. The source gives few details, but an error-handling issue in the router could cause internal directory listings to be shown when certain HTTP headers were not properly configured, which can disclose sensitive information. Upgrade to Moodle 4.5.7 or 5.0.3.

Written 3 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.3 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CNA (fedora)
  • CISA KEV Not listed.
  • EPSS 0.0030, the 22nd percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:26 UTC First seen by agentprime
  2. 31 Oct 2026, 14:26 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.