Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's io.netty:netty-handler is affected in versions from 4.2.0.Final before 4.2.17.Final and from 4.1.x before 4.1.137.Final. A remote, unauthenticated attacker can send a TLS ClientHello split across records so that Netty falls back to the default SslContext instead of the per-SNI one. This bypasses mTLS only when the default context does not require client authentication and no other peer-certificate check exists. Upgrade to 4.2.17.Final or 4.1.137.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.1 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0032, the 24th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:18 UTC First seen by agentprime
- 31 Oct 2026, 14:18 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-c4c3-7fpv-j4q5
- OSV: GHSA-c4c3-7fpv-j4q5
- github.com/netty/netty/security/advisories/GHSA-c4c3-7fpv-j4q5
- nvd.nist.gov/vuln/detail/CVE-2026-75595
- github.com/netty/netty/pull/17213
- github.com/netty/netty/pull/17217
- github.com/netty/netty/commit/1b5abc6443b63726c72cdd285af2feb7ddbb8ff7
- github.com/netty/netty/commit/9e0519239108a69b7e9bbc5e9182ee139a0d7961
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.137.Final
- github.com/netty/netty/releases/tag/netty-4.2.17.Final