Advisory record · GHSA-c27j-76xg-6x4f

Kirby CMS vulnerable to user enumeration in the brute force protection

CVSS 6.5 MediumEPSS 0.0079 · 56th percentile

Published by the GitHub Advisory Database at 18 Oct 2022, 21:16 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
getkirby/cmsPackagist<3.5.8.2 || >=3.6.0, <3.6.6.2 || >=3.7.0, <3.7.5.1 || >=3.8.0, <3.8.13.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1
Identifiers
GHSA-c27j-76xg-6x4f · CVE-2022-39315 · PKSA-5k7b-5skk-nstj
Weakness (CWE)
CWE-204 · CWE-209 · CWE-668
Published
18 Oct 2022
Updated
16 Feb 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Kirby CMS (getkirby/cms) versions before 3.5.8.2, from 3.6.0 before 3.6.6.2, from 3.7.0 before 3.7.5.1, and from 3.8.0 before 3.8.1 are vulnerable to user enumeration through the login form's brute force protection. An attacker who can reach the login form can submit requests from two or more IP addresses past the trial limit and tell existing accounts from invalid ones, because only existing accounts get blocked and the random delay is skipped once the limit is reached. Upgrade to 3.5.8.2, 3.6.6.2, 3.7.5.1, 3.8.1 or a later version.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0079, the 56th percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:32 UTC First seen by agentprime
  2. 31 Oct 2026, 14:32 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.