Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Tomcat (org.apache.tomcat:tomcat, tomcat-embed-core and tomcat-catalina) versions 11.0.0-M1 through 11.0.24, 10.1.0-M1 through 10.1.57, 9.0.0.M1 through 9.0.120, and older unsupported versions are affected. A client using DIGEST authentication can, under specific nonce count conditions, replay one captured request and bypass authentication. Upgrade to 11.0.25, 10.1.58, or 9.0.121.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.8 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.0076, the 55th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV