Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
DSpace (org.dspace:dspace-api) versions 8.0 through 8.3, 9.0 through 9.2, and 10.0-rc1 and later before 10.0 are affected by a remote code execution flaw in Velocity templates used for COAR Notify/LDN messages. An attacker needs DSpace administrator credentials, and when chained with a related path traversal issue, may be able to execute Java from templates. Upgrade to 8.4, 9.3, or 10.0; alternatively, set ldn.enabled=false in dspace.cfg or local.cfg, since LDN is disabled by default.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.0 | High | 3.1 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0087, the 59th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV