Advisory record · GHSA-9x4q-3gxw-849f

JupyterHub has a privilege escalation vulnerability with the `admin:users` scope

CVSS 7.2 HighEPSS 0.0059 · 48th percentile

Published by the GitHub Advisory Database at 8 Aug 2024, 14:37 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
jupyterhubPyPI<4.1.6 || >=5.0.0, <5.1.04.1.6, 5.1.0
Identifiers
GHSA-9x4q-3gxw-849f · BIT-jupyterhub-2024-41942 · CVE-2024-41942 · PYSEC-2024-200
Weakness (CWE)
CWE-274
Published
8 Aug 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

JupyterHub versions before 4.1.6 and from 5.0.0 before 5.1.0 are vulnerable to privilege escalation. A user who has been granted the admin:users scope can make themselves a full admin, gaining the additional scopes that admin users receive. Upgrade to JupyterHub 4.1.6 or 5.1.0. The source notes the impact is relatively small, since admin:users is already highly privileged.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.2 High 3.1 CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0059, the 48th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:35 UTC First seen by agentprime
  2. 31 Oct 2026, 14:35 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.