Advisory record · GHSA-9vc3-vm42-fjhm

Moodle's mod_data edit/delete pages pass CSRF token in GET parameter

CVSS 3.1 LowEPSS 0.0037 · 30th percentile

Published by the GitHub Advisory Database at 25 Apr 2025, 15:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
moodle/moodlePackagist<4.3.12 || >=4.3.0-beta, <4.3.12 || >=4.4.0-beta, <4.4.8 || >=4.5.0-beta, <4.5.44.3.12, 4.4.8, 4.5.4
Identifiers
GHSA-9vc3-vm42-fjhm · BIT-moodle-2025-3637 · CVE-2025-3637 · PKSA-fvfh-pt1s-3tmx
Weakness (CWE)
CWE-598
Published
25 Apr 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Moodle (moodle/moodle on Packagist) is affected in the mod_data module's edit and delete pages, which expose the CSRF token in a GET parameter, in versions before 4.3.12, from 4.4.0-beta before 4.4.8, and from 4.5.0-beta before 4.5.4. The source says an attacker could see this token through the site's URL, which weakens protection against cross-site request forgery, but it gives few details on the conditions required. Upgrade to 4.3.12, 4.4.8, or 4.5.4, which are listed as fixed versions.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.1 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N CNA (fedora)
  • CISA KEV Not listed.
  • EPSS 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:03 UTC First seen by agentprime
  2. 31 Oct 2026, 14:03 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.