Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The PyPI packages brotli (1.0.3 up to but not including 1.2.1) and brotlicffi (1.0.3 up to but not including 1.2.1.0) have an out-of-bounds write in the Brotli decoder. A remote, unauthenticated attacker can use a crafted Brotli-compressed stream to corrupt adjacent memory, disclose memory contents, cause a denial of service, or possibly execute arbitrary code. Upgrade to brotli 1.2.1 or brotlicffi 1.2.1.0.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.2 | Critical | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | CNA (Google) |
- CISA KEV Listed since 27 Oct 2026: known to be exploited.
- EPSS 0.83, the 99th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 22 Oct 2026, 13:35 UTC Confirmed by the CVE List
- 22 Oct 2026, 14:17 UTC Confirmed by NVD
- 22 Oct 2026, 15:32 UTC Confirmed by GitHub Advisory Database
- 31 Oct 2026, 14:07 UTC First seen by agentprime
- 31 Oct 2026, 14:07 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9v8h-qqgm-4m35
- OSV: GHSA-9v8h-qqgm-4m35
- github.com/andybalholm/brotli/security/advisories/GHSA-c9gr-gmg4-2vqv
- github.com/andybalholm/brotli/commit/33c2a9884269798192b5ecf171288f98939dbe42
- github.com/andybalholm/brotli/releases/tag/v1.2.7
- github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b