Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The pgp crate for Rust (crates.io) is affected in versions before 0.14.1. A remote attacker can supply crafted, malformed OpenPGP data, such as messages, keys, or cleartext signatures, to trigger a panic that halts the program, causing denial of service. Upgrade to pgp 0.14.1 or later; no workaround is listed.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0047, the 40th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9rmp-2568-59rv
- OSV: GHSA-9rmp-2568-59rv
- crates.io/crates/pgp
- rustsec.org/advisories/RUSTSEC-2024-0447.html
- github.com/rpgp/rpgp/commit/91b9f517f3bc38e7b14518a156bff81ee69301fc
- github.com/radicallyopensecurity/ros-website/blob/8169b16fc138a0b0dde14dd0e222d1279701b4d3/ros-public-reports/ROS%20-%20NLNet%20-%20rPGP%20-%202024.pdf