Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Affected versions of org.dspace:dspace-api are 8.0 through 8.3, 9.0 through 9.2, and 10.0-rc1 range as listed in the package data. A path traversal flaw in the LDN (COAR Notify) template handling lets an attacker with DSpace administrator credentials make the server read an arbitrary file and interpret it as a Velocity template, which could disclose information or lead to arbitrary code execution. Upgrade to 8.4, 9.3, or 10.0; if that is not possible, set ldn.enabled=false in dspace.cfg or local.cfg, since LDN is disabled by default.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.5 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:L | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0037, the 31st percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV