Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-9q9j-q6p8-xq58 affects the npm package fastify before 5.12.2. Header schemas that use JSON Schema `dependencies` with mixed-case header names are not normalized correctly, so a dependency between headers can be silently skipped. An unauthenticated remote client can send the header that activates a privileged path while omitting the dependent header, bypassing that schema-enforced control. Upgrade to fastify 5.12.2 or later, which also appears in 6.0.0; if upgrading is not possible, use lowercase header-schema names or enforce the check in an onRequest or preValidation hook.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N | CNA (openjs) |
- CISA KEV Not listed.
- EPSS 0.0052, the 44th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:34 UTC First seen by agentprime
- 31 Oct 2026, 13:34 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9q9j-q6p8-xq58
- OSV: GHSA-9q9j-q6p8-xq58
- github.com/fastify/fastify/security/advisories/GHSA-9q9j-q6p8-xq58
- nvd.nist.gov/vuln/detail/CVE-2026-84428
- github.com/fastify/fastify/commit/179619c8e99d54924309b9933402151ef9af37e0
- cna.openjsf.org/security-advisories.html
- github.com/fastify/fastify
- github.com/fastify/fastify/releases/tag/v5.12.2