Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-9m94-w2vq-hcf9 affects kubevirt.io/kubevirt versions before 1.7.0-beta.0. An attacker who can obtain the UID of a running VMI and create a pod in the same namespace can give it labels that make virt-controller associate the pod with that VMI, which can lead to incorrect status updates and a denial of service for the VMI. Upgrade to kubevirt.io/kubevirt 1.7.0-beta.0 or later. The source gives few details on workarounds.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0041, the 35th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:14 UTC First seen by agentprime
- 31 Oct 2026, 14:14 UTC Confirmed by OSV