Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Docling versions from 2.27.0 before 2.131.0, and docling-slim versions from 2.92.0 before 2.131.0, import the import-time code of installed third-party plugin modules even when allow_external_plugins is False, which is meant to block them. An attacker who can get a malicious or compromised package with a docling plugin entry point installed into the environment can run code in the docling process. Upgrade docling and docling-slim to 2.131.0. For older versions, install only trusted packages in environments that run docling.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.7 | Medium | 3.1 | CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0012, the 1st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:08 UTC First seen by agentprime
- 31 Oct 2026, 14:08 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9jxx-vjrv-h2rq
- OSV: GHSA-9jxx-vjrv-h2rq
- github.com/docling-project/docling/security/advisories/GHSA-9jxx-vjrv-h2rq
- nvd.nist.gov/vuln/detail/CVE-2026-105745
- github.com/docling-project/docling/pull/4413
- github.com/docling-project/docling/commit/0f443b3786e98688a2da3b7c8f56fe5e46af876c
- github.com/docling-project/docling
- github.com/docling-project/docling/releases/tag/v2.131.0