Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Keylime registrar versions >=7.12.0, <7.12.1 are vulnerable to a denial-of-service attack after an update. Version 7.12.0 rejects database data stored by versions 7.8.0 and later, so an attacker who registered many agents with different UUIDs before the update can make queries against those entries fail. Upgrade to Keylime 7.12.1 or later. As a workaround, remove the registrar database and re-register all agents.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L | CNA (redhat) |
- CISA KEV Not listed.
- EPSS 0.0040, the 34th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 15 Mar 2025, 08:50 UTC Confirmed by the CVE List
- 15 Mar 2025, 09:15 UTC Confirmed by NVD
- 31 Oct 2026, 14:42 UTC First seen by agentprime
- 31 Oct 2026, 14:42 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9jxq-5x44-gx23
- OSV: GHSA-9jxq-5x44-gx23
- github.com/keylime/keylime/security/advisories/GHSA-9jxq-5x44-gx23
- nvd.nist.gov/vuln/detail/CVE-2025-1057
- github.com/keylime/keylime/commit/e08b10d86c3717006774e787542c190e2ba24fc7
- access.redhat.com/security/cve/CVE-2025-1057
- bugzilla.redhat.com/show_bug.cgi?id=2343894
- github.com/advisories/GHSA-9jxq-5x44-gx23
- github.com/ansasaki/keylime/tree/base64_bytes
- github.com/keylime/keylime
- github.com/keylime/rust-keylime
- github.com/pypa/advisory-database/tree/main/vulns/keylime/PYSEC-2026-1488.yaml
- pypi.org/project/keylime