Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Versions of openlit from 1.36.2 up to but not including 1.37.1 are affected, due to GitHub Actions workflows in the project's repository that run untrusted code from forked pull requests with base-repository privileges. An attacker who can open a pull request from a fork could run code with a write-privileged token and access to sensitive repository secrets, such as API keys and a Google Cloud service account key. Upgrade openlit to version 1.37.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 10.0 | Critical | 3.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0045, the 39th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:04 UTC First seen by agentprime
- 31 Oct 2026, 15:04 UTC Confirmed by OSV