Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Yamcs (Maven package org.yamcs:yamcs-core) versions before 5.12.0 are vulnerable to unauthenticated directory traversal, which lets a remote attacker read any file on the underlying host's operating system, such as sensitive system files. No authentication is needed. Upgrade to yamcs-core 5.12.0 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.017, the 77th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:19 UTC First seen by agentprime
- 31 Oct 2026, 14:19 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9jg3-g3wh-w9pj
- OSV: GHSA-9jg3-g3wh-w9pj
- github.com/yamcs/yamcs/security/advisories/GHSA-9jg3-g3wh-w9pj
- github.com/yamcs/yamcs/commit/c7dfd24e469ae1086c23e0fe04401cb1ce4260d4
- github.com/yamcs/yamcs/commit/f4bc588880c166849e983aa8f65b9c8107d06091
- github.com/yamcs/yamcs
- github.com/yamcs/yamcs/releases/tag/yamcs-5.11.13
- github.com/yamcs/yamcs/releases/tag/yamcs-5.12.0