Advisory record · GHSA-9hcf-v7m4-6m2j

vLLM allows clients to crash the openai server with invalid regex

CVSS 6.5 MediumEPSS 0.0051 · 43rd percentile

Published by the GitHub Advisory Database at 28 May 2025, 19:42 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.8.0, <0.9.00.9.0
Identifiers
GHSA-9hcf-v7m4-6m2j · CVE-2025-48943 · PYSEC-2025-55
Weakness (CWE)
CWE-248
Published
28 May 2025
Updated
7 Aug 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vLLM versions 0.8.0 up to but not including 0.9.0 are affected. A client that sends an invalid regex while using structured output can crash the OpenAI-compatible server, causing a denial of service. The source gives few details about the required access level. Upgrade vLLM to version 0.9.0 or later.

Written 5 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
6.5 Medium 3.1 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.0051, the 43rd percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:40 UTC First seen by agentprime
  2. 31 Oct 2026, 14:40 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.