Advisory record · GHSA-9h6j-4ffx-cm84

Mattermost doesn't restrict domains LLM can request to contact upstream

CVSS 3.0 LowEPSS 0.0029 · 21st percentile

Published by the GitHub Advisory Database at 16 Apr 2025, 12:31 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
github.com/mattermost/mattermost/server/v8Go>=10.5.0, <10.5.1 || >=10.4.0, <10.4.3 || >=9.11.0, <9.11.10 || <8.0.0-20250218121836-2b5275d8713610.5.1, 10.4.3, 9.11.10, 8.0.0-20250218121836-2b5275d87136
Identifiers
GHSA-9h6j-4ffx-cm84 · CVE-2025-31363 · GO-2025-3622
Weakness (CWE)
CWE-201 · CWE-497 · CWE-1426
Published
16 Apr 2025
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Mattermost server (github.com/mattermost/mattermost/server/v8) versions before 8.0.0-20250218121836-2b5275d87136, from 9.11.0 through 9.11.9, from 10.4.0 through 10.4.2, and from 10.5.0 through 10.5.0 are affected. An authenticated user can use a prompt injection in the AI plugin's Jira tool to make the LLM contact arbitrary servers reachable by the victim, exfiltrating data. Upgrade to 8.0.0-20250218121836-2b5275d87136, 9.11.10, 10.4.3, or 10.5.1.

Written 1 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
3.0 Low 3.1 CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N CNA (Mattermost)
  • CISA KEV Not listed.
  • EPSS 0.0029, the 21st percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:14 UTC First seen by agentprime
  2. 31 Oct 2026, 14:14 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.