Advisory record · GHSA-9fm3-97px-rjf6

undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering

CVSS 5.9 MediumEPSS 0.0032 · 25th percentile

Published by the GitHub Advisory Database at 27 Oct 2026, 19:02 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
undicinpm>=5.15.0, <6.29.1 || >=7.0.0, <7.30.1 || >=8.0.0, <8.12.26.29.1, 7.30.1, 8.12.2
Identifiers
GHSA-9fm3-97px-rjf6 · CVE-2026-109932
Weakness (CWE)
CWE-400 · CWE-405 · CWE-770
Published
27 Oct 2026
Updated
27 Oct 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

undici's WebSocket client, including Node.js's bundled globalThis.WebSocket, is affected in versions from 5.15.0 up to but not including 6.29.1, 7.30.1, and 8.12.2 (npm undici, with 5.x, 6.x, 7.x and 8.x in scope). A remote, unauthenticated malicious or compromised WebSocket server can send many small PING frames without reading the client's automatic PONG replies, causing unbounded memory growth and process termination, which is an availability impact. Upgrade to undici 6.29.1, 7.30.1, or 8.12.2, which bound the outbound queue; the source lists no workarounds.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
5.9 Medium 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H CNA (openjs)
  • CISA KEV Not listed.
  • EPSS 0.0032, the 25th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 13:33 UTC First seen by agentprime
  2. 31 Oct 2026, 13:33 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.