Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The rssn crate, versions 0.1.20 up to but not including 0.2.9, has a code injection flaw in its JIT compilation engine, which is exposed through its CFFI interface. An attacker who can supply crafted parameters or instruction sequences through that interface may be able to run arbitrary code at the privilege level of the host process. Upgrade to rssn 0.2.9. If you cannot upgrade, the source suggests running the library in a restricted sandbox, avoiding root or administrator privileges, and disabling the JIT engine where the library allows it.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 9.4 | Critical | 4.0 | CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0022, the 12th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:24 UTC First seen by agentprime
- 31 Oct 2026, 14:24 UTC Confirmed by OSV