Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Contao core-bundle versions 4.0.0 up to 4.13.57, 5.0.0-RC1 up to 5.3.42, and 5.4.0-RC1 up to 5.6.5 are affected. An attacker needs a backend user account with precise control over the contents of template closures, and can then execute arbitrary PHP functions that do not have required parameters. Upgrade to Contao 4.13.57, 5.3.42 or 5.6.5. The source suggests a workaround is to manually patch the Contao\Template::once() method.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 6.6 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0019, the 8th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:26 UTC First seen by agentprime
- 31 Oct 2026, 14:26 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-98vj-mm79-v77r
- OSV: GHSA-98vj-mm79-v77r
- github.com/contao/contao/security/advisories/GHSA-98vj-mm79-v77r
- nvd.nist.gov/vuln/detail/CVE-2025-65960
- github.com/contao/contao/commit/577d7fdd5b1ca84f65f034ff556865422f0a3bd1
- github.com/contao/contao/commit/676f0855d39007ac9a0dbe7ae6a7414cba2312a5
- github.com/contao/contao/commit/ebf84c90e5679a67060f396b924ce4a3c3f206b3
- contao.org/en/security-advisories/remote-code-execution-in-template-closures
- github.com/contao/contao