Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Apache Camel's camel-support package is affected in versions 3.10.0 before 3.22.4, 4.0.0 before 4.8.5, and 4.9.0 before 4.10.2. A remote attacker can send HTTP requests with parameters that are turned into Camel headers, which can change the behavior of some components such as camel-bean or camel-exec. Users should upgrade to 3.22.4, 4.8.5, or 4.10.2, depending on their release line.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 4.2 | Medium | 3.1 | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L | GitHub Advisory Database |
- CISA KEV Not listed.
- EPSS 0.76, the 99th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 15:11 UTC First seen by agentprime
- 31 Oct 2026, 15:11 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-96v5-c2h5-56hm
- OSV: GHSA-96v5-c2h5-56hm
- nvd.nist.gov/vuln/detail/CVE-2025-29891
- github.com/apache/camel/commit/23a833eec6131a3cdce6e4b1b40b3ac2035b6adf
- github.com/apache/camel/commit/45a6b74f7f8af8fd58f197566938a9534392a624
- camel.apache.org/security/CVE-2025-27636.html
- camel.apache.org/security/CVE-2025-29891.html
- github.com/akamai/CVE-2025-27636-Apache-Camel-PoC
- github.com/apache/camel
- issues.apache.org/jira/browse/CAMEL-21828