Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
GHSA-964w-f6gj-5236 affects goshs in the Go modules github.com/patrickhener/goshs/v2 and goshs.de/goshs/v2 before 2.1.5-0.20260727065949-f3ef599e4091, and github.com/patrickhener/goshs and goshs.de/goshs at or below 1.1.4, with no fixed version listed for the latter two. A request with a trailing slash can bypass the block list and the rule that never serves the ACL file, with no authentication bypass. Upgrade the v2 modules to 2.1.5-0.20260727065949-f3ef599e4091 or later. The source lists no fix for the 1.x modules.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 5.3 | Medium | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0044, the 38th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:50 UTC First seen by agentprime
- 31 Oct 2026, 14:50 UTC Confirmed by OSV