Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
phpMyAdmin versions from 2.11.0 before 2.11.10 are affected. The source says libraries/File.class.php uses predictable filenames for temporary files, but it gives no details on the impact or how an attacker would exploit it. Upgrade to phpMyAdmin 2.11.10 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
No source has published a CVSS score for this record yet.
- CISA KEV Not listed.
- EPSS 0.027, the 86th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:32 UTC First seen by agentprime
- 31 Oct 2026, 14:32 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-9645-6g72-2pv8
- OSV: GHSA-9645-6g72-2pv8
- nvd.nist.gov/vuln/detail/CVE-2008-7252
- github.com/phpmyadmin/composer
- web.archive.org/web/20100613071447/http://secunia.com/advisories/38211
- web.archive.org/web/20100613071509/http://secunia.com/advisories/39503
- web.archive.org/web/20110729050522/http://www.securityfocus.com/bid/37826
- lists.opensuse.org/opensuse-security-announce/2010-01/msg00007.html
- phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/QA_2_11/phpMyAdmin/libraries/File.class.php?r1=11528&r2=11527&pathrev=11528
- phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin?view=rev&revision=11528
- www.debian.org/security/2010/dsa-2034
- www.phpmyadmin.net/home_page/security/PMASA-2010-2.php