Advisory record · GHSA-94f4-hr76-p5j6

vLLM: OpenAI auth bypass

CVSS 9.1 CriticalCriticalEPSS 0.012 · 67th percentile

Critical, because:

  • CVSS score 9.1: 9.0 or more.

How we decide what’s critical

Published by the GitHub Advisory Database at 16 Jun 2026, 17:36 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
vllmPyPI>=0.3.0, <0.22.00.22.0
Identifiers
GHSA-94f4-hr76-p5j6 · CVE-2026-48746 · PYSEC-2026-226
Weakness (CWE)
CWE-444 · CWE-501
Published
16 Jun 2026
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

vllm versions 0.3.0 up to 0.22.0 have an authentication bypass in the OpenAI API server. An attacker with network access can send a crafted Host header to use the API without the configured API key. Upgrade to vllm 0.22.0. Deployments behind an RFC-conforming web server such as nginx are not affected.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
9.1 Critical 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.012, the 67th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:29 UTC First seen by agentprime
  2. 31 Oct 2026, 14:29 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.