Advisory record · GHSA-93x3-m7pw-ppqm

Mantis Bug Tracker (MantisBT) allows user account takeover in the signup/reset password process

CVSS 7.3 HighEPSS 0.012 · 68th percentile

Published by the GitHub Advisory Database at 13 May 2024, 14:57 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
mantisbt/mantisbtPackagist<2.26.22.26.2
Identifiers
GHSA-93x3-m7pw-ppqm · CVE-2024-34077 · PKSA-vn99-1c14-x82z
Weakness (CWE)
CWE-305 · CWE-620
Published
13 May 2024
Updated
10 Sept 2026

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Mantis Bug Tracker (MantisBT) versions before 2.26.2 from the Packagist package mantisbt/mantisbt have an insufficient access control flaw in the registration and password reset process. An attacker who can make brute-force requests to account_update.php while a victim's incomplete signup or reset request is pending may be able to reset that user's password and take over the account, which would give full access to it. The fix is to upgrade to version 2.26.2; the source also suggests reducing the verification token's validity by changing TOKEN_EXPIRY_AUTHENTICATED as a workaround.

Written 31 Oct 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.3 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L CNA (GitHub_M)
  • CISA KEV Not listed.
  • EPSS 0.012, the 68th percentile, on 6 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.

Timeline

  1. 31 Oct 2026, 14:05 UTC First seen by agentprime
  2. 31 Oct 2026, 14:05 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.