Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Netty's codec-http2 package is vulnerable in versions from 4.2.0 up to but not including 4.2.16.Final and from 4.1.0.Final up to but not including 4.1.136.Final. A remote, unauthenticated peer can send HTTP/2 DATA frames for a stream whose decompressor has already been closed, which leaks one direct ByteBuf per frame when HTTP/2 content decompression is enabled. Repeated over a long-lived connection, this can exhaust direct memory and crash the JVM with an OutOfMemoryError. Upgrade to 4.2.16.Final or 4.1.136.Final.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 7.5 | High | 3.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0066, the 52nd percentile, on 8 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-93wv-jw9v-4972
- OSV: GHSA-93wv-jw9v-4972
- github.com/netty/netty/security/advisories/GHSA-93wv-jw9v-4972
- nvd.nist.gov/vuln/detail/CVE-2026-56819
- github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- github.com/netty/netty
- github.com/netty/netty/releases/tag/netty-4.1.136.Final
- github.com/netty/netty/releases/tag/netty-4.2.16.Final