Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
The RabbitMQ Java client (com.rabbitmq:amqp-client, Maven) versions before 5.33.1 are vulnerable to a denial of service caused by unbounded recursion when parsing nested tables and arrays. A malicious AMQP server or man-in-the-middle can send a deeply nested structure, causing a StackOverflowError that kills the client I/O thread. Upgrade to amqp-client 5.33.1 or later.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (GitHub_M) |
- CISA KEV Not listed.
- EPSS 0.0073, the 54th percentile, on 7 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:16 UTC First seen by agentprime
- 31 Oct 2026, 14:16 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-93j5-89vc-pph4
- OSV: GHSA-93j5-89vc-pph4
- github.com/rabbitmq/rabbitmq-java-client/security/advisories/GHSA-93j5-89vc-pph4
- github.com/rabbitmq/rabbitmq-java-client/pull/2007
- github.com/rabbitmq/rabbitmq-java-client/pull/2008
- github.com/rabbitmq/rabbitmq-java-client/commit/09af76fce136f3136931654a0a1d43095c80e2f0
- github.com/rabbitmq/rabbitmq-java-client/commit/db89e34809fbc6ba4e946615f297f3684ccd0acc
- github.com/rabbitmq/rabbitmq-java-client
- github.com/rabbitmq/rabbitmq-java-client/releases/tag/v5.33.1