Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
PocketMine-MP versions below 4.23.1 and from 5.0.0 up to (but not including) 5.3.1 are affected. A remote attacker can crash the server by sending a LoginPacket containing malformed JSON, because the JSON mapper accepts NULL values in typed arrays that the server does not expect. Upgrade to 4.23.1 or 5.3.1, which include an updated JsonMapper fix; the source notes that a plugin-based workaround exists but is cumbersome.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 8.7 | High | 4.0 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N | CNA (VulnCheck) |
- CISA KEV Not listed.
- EPSS 0.0061, the 49th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 13:56 UTC First seen by agentprime
- 31 Oct 2026, 13:56 UTC Confirmed by OSV