Machine-written summary
Summary written by Claude Haiku from the source advisory. Not reviewed by a person.
Django versions 5.2 before 5.2.15 and 6.0 before 6.0.6 are vulnerable. The function has_vary_header() does not strip leading or trailing whitespace from Vary header values before comparing them, so a remote attacker can read cached responses for URLs whose responses contain whitespace-padded Vary values. Upgrade to Django 5.2.15 or 6.0.6. Earlier, unsupported series were not evaluated and may also be affected.
Not analysed yet
We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.
Severity and exploitation
| Score | Rating | CVSS | Vector | Source |
|---|---|---|---|---|
| 2.3 | Low | 4.0 | CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N | CNA (DSF) |
- CISA KEV Not listed.
- EPSS 0.0037, the 30th percentile, on 5 Nov 2026: FIRST’s estimate of the chance of exploitation in the next 30 days.
Timeline
- 31 Oct 2026, 14:29 UTC First seen by agentprime
- 31 Oct 2026, 14:29 UTC Confirmed by OSV
Sources
- GitHub Advisory Database: GHSA-923m-gv2p-w5qp
- OSV: GHSA-923m-gv2p-w5qp
- nvd.nist.gov/vuln/detail/CVE-2026-48587
- github.com/django/django/commit/1721035a72624aad7b38dd19b14013efd94b24b8
- github.com/django/django/commit/42aa0b3364d312e7c6472258d8b0e9c0277fbf22
- github.com/django/django/commit/9b62b0af71a14c657d19d95371630ba839e83d9a
- docs.djangoproject.com/en/dev/releases/security
- github.com/django/django
- github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2026-198.yaml
- groups.google.com/g/django-announce
- www.djangoproject.com/weblog/2026/jun/03/security-releases