Advisory record · GHSA-8xhv-gqm4-3w99

ZendFramework1 Potential Insufficient Entropy Vulnerability

CVSS 7.5 High

Published by the GitHub Advisory Database at 7 Jun 2024, 22:26 UTC. agentprime has not analysed this yet, so whether it affects any app is not known.

PackageEcosystemAffectedFixed in
zendframework/zendframework1Packagist>=1.12.0, <1.12.181.12.18
Identifiers
GHSA-8xhv-gqm4-3w99 · PKSA-85gv-59x4-jyqb
Weakness (CWE)
CWE-331
Published
7 Jun 2024
Updated
4 Dec 2024

Machine-written summary

Summary written by Claude Haiku from the source advisory. Not reviewed by a person.

Zend Framework 1 versions 1.12.0 through 1.12.17 (Packagist package zendframework/zendframework1) use rand() or mt_rand(), which are not cryptographically secure, in several random number generators, and the advisory also raises a possible issue with openssl_random_pseudo_bytes() in Zend_Crypt_Math::randBytes. An attacker who can brute force the generated values could potentially obtain information disclosure. Upgrade to version 1.12.18. The source gives few details on the exact affected methods and the attack conditions.

Written 4 Nov 2026.

Not analysed yet

We haven’t published our analysis of this Advisory yet. Once a person has reviewed it, this page will say what’s vulnerable, what has to be true for your app to be affected, and how to check.

Severity and exploitation

ScoreRatingCVSSVectorSource
7.5 High 3.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N GitHub Advisory Database
  • CISA KEV Not listed.
  • EPSS No score.

Timeline

  1. 31 Oct 2026, 14:28 UTC First seen by agentprime
  2. 31 Oct 2026, 14:28 UTC Confirmed by OSV

Sources

Facts on this page come from the GitHub Advisory Database (CC-BY 4.0), OSV and the other sources listed, as published. We don’t reproduce full advisory descriptions, which can contain exploit code.